Download Cisco.Certkiller.300-101.2017-09-25.1e.80q.vcex

Download Dump

File Info

Exam Implementing Cisco IP Routing (ROUTE v2.0)
Number 300-101
File Name Cisco.Certkiller.300-101.2017-09-25.1e.80q.vcex
Size 3.84 Mb
Posted September 25, 2017
Downloaded 13



How to open VCEX & EXAM Files?

Files with VCEX & EXAM extensions can be opened by ProfExam Simulator.

Purchase

Coupon: MASTEREXAM
With discount: 20%

 
 



Demo Questions

Question 1

Examine the following output of the show ip ospf interface command. 
  

 
What would be the effect of executing the auto-cost reference bandwidth 2000 command on Router43 in router OSPF mode?

  • A: the cost of the Serial interface would increase to 20
  • B: the cost of the FastEthernet interfaces would increase to 2000
  • C: the cost of the Serial interface would increase to 647
  • D: the cost of the FastEthernet interfaces would increase to 20

Correct Answer: D

If the auto-cost reference bandwidth 2000 command is executed in router OSPF mode it will result in a cost to the FastEthernet interfaces of 20. The formula for arriving at the cost is:
reference bandwidth / interface bandwidth = cost 
The default reference bandwidth for FastEthernet is 100 Mbps. If the reference bandwidth is set at 2000 Mbps using the auto-cost reference command, and the FastEthernet interface has a bandwidth of 100 Mbps, the resulting cost is 20 (2000 / 100 = 20). 
The auto-cost reference bandwidth command is executed in router OSPF mode to affect all interfaces. Alternatively, the cost of each interface can be set separately with the ip ospf cost command issued in interface configuration mode. The two commands can also be used in combination: you can set all interfaces with the auto-cost reference bandwidth command, and then set a single interface to a different cost with the ip ospf cost command. 
The command would not result in the cost of the Serial interface increasing to 20 or to 647. With a reference bandwidth of 2000 Mbps and interface bandwidth of 1544 kbps (the default bandwidth of a serial interface), the resulting cost would be 1294. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify OSPF path preference 
References:
Cisco > Home > Support > Technology Support > IP > IP Routing > Technology Information > Technology White Paper > OSPF Design Guide > OSPF Cost 
Cisco > Cisco IOS IP Routing: OSPF Command Reference > show ip ospf interface
Cisco > Cisco IOS IP Routing: OSPF Command Reference > auto-cost




Question 2

You instructed your assistant to configure redistribution of OSPF routes into EIGRP on Router 9. The routes are not being advertised to EIGRP and you are troubleshooting the problem. The EIGRP process ID is 100 and the OSPF process ID is 20. When you ask your assistant what commands were executed, you are shown the following:
Router9(config)# router eigrp 100 
Router9(config-router)# redistribute ospf 20 
What is the problem? 

  • A: no metric was configured
  • B: the process IDs are incorrect
  • C: the redistribute command is executed at the interface configuration prompt
  • D: the redistribute command is executed at the global configuration prompt

Correct Answer: A

The problem is that the metric was not configured. Some routing protocols require that a metric be provided for the redistributed routing protocol or route redistribution will not occur successfully. RIP and EIGRP both require that a metric be provided. IS-IS and OSPF do not have this requirement. 
When you redistribute traffic into EIGRP without specifying a metric, then the default metric applied is zero, the route will be treated as unreachable, and the route will not be advertised. The addition of the metric parameter as shown below would solve this issue:
Router9(config)# router eigrp 100 
Router9(config-router)# redistribute ospf 20 metric 10000 100 255 1 1500 
In this example, 1000 is the bandwidth, 100 is the delay, 255 is the reliability, 1 is the load, and 1500 is the MTU. 
The process IDs are correct in the original scenario, and the command was executed in the correct context. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify redistribution between any routing protocols or routing sources 
References:
Cisco > Home > Support > Technology Support > IP > IP Version 6 > Configure > Configuration Examples and Technotes > Redistributing Routing Protocols




Question 3

Which command should be executed on all ABRs in an area to configure it as a totally stubby area?

  • A: Router(config-router)# area process-id stub [no-summary]
  • B: Router(config-router)# area area-id [no-summary] stub
  • C: Router(config-router)# area area-id stub [no-summary]
  • D: Router(config-ospf)# area router-id [no-summary] stub

Correct Answer: C

The correct syntax for the area stub command to configure a totally stubby area is shown below:
Router(config-router)# area stub [no-summary] 
Note that the optional no-summary keyword is used only on area border routers (ABRs) to block summary link advertisements into the stub area. This option creates a totally stubby area. All internal routers in the area need only the stub keyword without the no summary keyword. 
It is very important to configure the command consistently on all routers within the area. OSPF sends its stub status (on or off) in its hello packets. If two neighbors have conflicting stub status, for example, if one indicates that a stub is present and the other indicates that no stub is present, they will not form an adjacency, and you end up with no OSPF communication over that link. 
The other options are either using incorrect syntax or being executed at an incorrect prompt. The area stub command should be executed at the OSPF router configuration prompt. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify network types, area types, and router types 
References:
Cisco > Home > Support > Technology Support > IP Routing > Design > Design Technotes > What Are OSPF Areas and Virtual Links? > What Are Areas, Stub 
Areas, and Not-So-Stubby Areas? 
Cisco > Cisco IOS IP Routing: OSPF Command Reference > area stub




Question 4

You have configured a BGP network with several routers in the same autonomous system (AS). There are three possible routes from router A to router B in the network. The following conditions exist:
All three routes have the same weight 
All three routes were originated locally through the use of the network command 
The bgp default local-preference 50 command is executed for all three routes 
All three routes have different lists of AS through which they travel  
Which of the following parameters is used to select the best path among the three routes?

  • A: Weight
  • B: MED
  • C: LOCAL_PREF
  • D: AS_Path

Correct Answer: D

The AS_Path parameter is used to select the best path among the three routes. To select the best path from router A to router B, BGP analyses various BGP attributes that are set during the configuration of the network. The key BGP attributes and the order in which they are checked are as follows:
1.Weight - highest weight is selected 
2.LOCAL_PREF - highest LOCAL_PREF is selected 
3.Locally originated routes - local routes are selected 
4.AS_PATH - shortest AS_PATH is selected 
5.Origin type - lowest origin type is selected 
6.Multi-exit Discriminator (MED) - lowest MED is selected  
Because the weight attribute is same for all three routes, BGP checks the value of the LOCAL_PREF attribute. However, this attribute is also same for the three routes because the bgp default local-preference 50 command was executed for the three routes, which sets the value of the LOCAL_PREF attribute to 50 for those routes. 
BGP then checks whether any of the routes were locally originated using either the network or aggregate commands. As stated in the scenario, all three routes were locally originated with the network command during BGP configuration. Consequently, BGP analyzes the value of the AS_PATH attribute. This attribute refers to a list of AS numbers that are traversed by a particular route. The route with the shortest AS_PATH is selected as the best path. 
The weight attribute is not used to select the best path in this case. The weight attribute for all three routes is the same. If this attribute were different for the three routes, then the route with the highest weight would be considered the best path. 
The MED attribute is not used to select the best path in this case. The MED, or multi-exit discriminator, specifies the route into an AS that has more than one entry points. A route with the lowest MED is selected as the best path. However, in this case, the MED attribute is not considered because the AS_PATH attribute is different for the three routes. If the AS_PATH attribute for the three routes were the same, then the MED attribute would have been considered. 
The LOCAL_PREF attribute is not used to select the best path. The LOCAL_PREF attribute is checked if the weight attribute for the routes is same. The LOCAL_PREF attribute refers to the local preference, which specifies the route that has preference to exit the AS for a given destination network. The route with the highest LOCAL_PREF value is selected as the best path. However, the bgp default local-preference 50 command was executed for all three routes. Hence, this attribute is not considered to select the best path between the BGP routers A and B. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Explain BGP attributes and best-path selection 
References:
Cisco > Home > Support > Technology Support > IP > IP Routing > Design > Design TechNotes > BGP Best Path Selection Algorithm




Question 5

Examine the exhibit by pressing the Exhibit(s) button. 

 
You are to configure R1 to belong to area 5. This area does not accept routes from the external AS or summary routes from any other internal areas. Refer to the IP addressing below. 
R1 - int E0 - 192.168.5.1/24 
R2 - int E0 - 192.168.5.2/24 
R2 - int E1 - 192.168.0.2/24 
R3 - int E0 - 192.168.0.3/24 
Which configuration commands are required to correctly configure R1?

  • A: R1(config)# router ospf 10 
    R1(config-router)# area 5 no-summary stub 
    R1(config-router)# network 192.168.5.0 0.0.0.255 area 5
  • B: R1(config)# router ospf 5 
    R1(config-router)# area 5 stub 
    R1(config-router)# network 192.168.5.0 0.0.0.255 area 5
  • C: R1(config)# router ospf 10 
    R1(config-router)# area 5 stub 
    R1(config-router)# network 192.168.5.0 255.255.255.0 area 5 
  • D: R1(config)# router ospf 5 
    R1(config-router)# area 5 stub no-summary 
    R1(config-router)# network 192.168.5.0 255.255.255.0 area 5

Correct Answer: B

All routers within a stub area must be configured as stub, or adjacencies will not form. Besides the command to enable OSPF and the command to identify the area, the only other required command identifies the area as a stub. At the area border router (ABR), R2, the no-summary keyword is required. The following commands are required to configure R1:
R1(config)# router ospf 5 
R1(config-router)# area 5 stub 
R1(config-router)# network 192.168.5.0 0.0.0.255 area 5 
A totally stubby area does not accept any external network LSAs (Type 5) or any inter-area summary LSAs (Types 3 and 4) from entering the area. Use the area stub command with the no-summary keyword on the ABR only to configure a totally stubby area. 
The correct syntax for the area stub command is shown below:
Router(config-router)# area area-id stub [no-summary] 
Note that the optional no-summary keyword is used only on ABRs to block summary link advertisements into the stub area. This option creates a totally stubby area. 
It is very important to configure the command consistently on all routers within the area. OSPF sends its stub status (on or off) in its hello packets. 
If two neighbors have conflicting stub status, they will not form an adjacency, and you end up with no OSPF communication over that link. 

 

Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify network types, area types, and router types 
References:
Cisco > Home > Support > Technology Support > IP Routing > Design > Design Technotes > What Are OSPF Areas and Virtual Links? > What Are Areas, Stub Areas, and Not-So-Stubby Areas? 
Cisco IOS Master Command List, Release 12.4 > a through b > area stub




Question 6

Which of the following commands will display information about Type 4 LSAs?

  • A: show ip ospf database external
  • B: show ip ospf database asbr-summary
  • C: show ip ospf database summary
  • D: show ip ospf database router

Correct Answer: B

The command show ip ospf database asbr-summary will display information about Type 4 LSAs. These LSAs provide next-hop information for areas that are receiving Type 5 or external LSAs. Consider the following sample output of the show ip ospf database asbr-summary command:

 

The output shows that the router that sent this LSA is at 172.16.241.75. The router functioning as the ASBR is at 172.16.245.63. The advertising router, located at 172.16.241.75, is broadcasting that its best metric to reach the ASBR at 172.16.254.63 is 1. 
The command show ip ospf database external will not display information about Type 4 LSAs. It will display information about Type 5 LSAs, or External Link LSAs, instead of ASBR summary links, which are Type 4 LSAs. 
The command show ip ospf database summary will not display information about Type 4 LSAs. It will display information about summary links, or Type 3 LSAs, that are generated by an ABR, not summary links generated by an ASBR. 
The command show ip ospf database router will not display information about Type 4 LSAs. It will display information about router links, or Type 1 LSAs, instead of ASBR summary links, which are Type 4 LSAs. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Describe OSPF packet types 
References:
Cisco > Cisco IOS IP Routing: OSPF Command Reference > show ip ospf database




Question 7

You have a router that is running both OSPF and RIP. You have configured this router to perform mutual redistribution between the two protocols. The following conditions exist:
The S0/0 interface, which is configured for RIP, is routing for the 172.16.5.0/24 network. 
The S0/1 interface, which is configured for OSPF, is routing for the 172.16.6.32/28 network.  
Users in the RIP domain are unable to connect to devices in the OSPF domain.  
What must be done to allow the OSPF routes to be redistributed into the RIP domain? (Choose two. Each correct answer is part of the solution.)

  • A: Create a static route that points to 172.16.6.0/24 with a next hop of null0.
  • B: Execute the passive-interface command on S0/0.
  • C: Create a loopback address on the router
  • D: Redistribute static routes into RIP.

Correct Answer: AD

The OSPF domain has a different mask than the RIP domain, and they are on the same major network. The OSPF domain's mask is also longer than the RIP domain's mask. Therefore, the RIP domain will not advertise routes learned from OSPF and redistributed into RIP. To solve this problem, you can create a static route to the major (classful) network 172.16.6.0/24, which includes all of the subnets in the OSPF domain, set the destination as null0, and then redistribute static routes into RIP. The following commands would enable this process:
router1(config)# ip route 172.16.5.0 255.255.255.0 null0 
router1(config)# router rip 
router1(config-router)# redistribute static 
router1(config-router)# default metric 1 
You should include the metric as well to ensure redistribution. This will allow the 172.16.5.0/24 network to be advertised to the RIP domain and, when the frames arrive at the null0 interface, will ensure the routing table of the router will have routes to the specific subnets of the OSPF domain. 
You should not execute the passive-interface command. This would prevent the interface from advertising either RIP or OSPF routes, and would only allow RIP updates inbound. This would not solve the problem and will create additional problems when the router is unable to advertise RIP routes to the other routers in the RIP domain. 
You should not create a loopback address on the router. Loopback addresses are logical addresses that can be created and used as the source of routing updates. 
Under normal circumstances, if routing updates are sourced from a physical interface and the interface goes down, the route will be removed from the routing tables. Since a loopback interface cannot go down, it provides the advantage of keeping a route in the tables even if the physical interface that services the route goes down. Loopback interfaces are of no help in solving the redistribution problem. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify manual and autosummarization with any routing protocol 
References:
Cisco > Home > Support > Technology Support > IP > IP Routing > Design > Design Technotes > Redistributing Between Classful and Classless Protocols: EIGRP
or OSPF into RIP or IGRP




Question 8

You are the network administrator for a large software organization. You designed the LAN in the organization's main building for connecting the internal LAN to a 
WAN as shown below:

 
You have configured EIGRP with the variance parameter set to 3 on all the routers to enable unequal load balancing from the 172.16.1.0 network to the WAN. The 
delay configured on each of the routers is shown in the LAN diagram, and the K values are set as follows:
K1 = 0 
K2 = 0 
K3 = 1 
K4 = 0 
K5 = 0 
Which of the following paths are entered into the routing tables as a result of the unequal load balancing configured on the routers? (Choose all that apply.)

  • A: RA-RB-RD-RH-RK
  • B: RA-RB-RE-RI-RK
  • C: RA-RC-RF-RI-RK
  • D: RA-RC-RG-RJ-RK 

Correct Answer: B

The only path is entered in the routing table as a result of the unequal load balancing configured on the routers:
RA-RB-RE-RI-RK 
In EIGRP networks, bandwidth and delay are the default factors for calculating the metric/cost for a given route. Additional factors such as load and reliability can be considered in the computation of the EIGRP metric, as given in the following formula:
Metric = [K1 * bandwidth + (K2 * bandwidth) / (256 - load) + K3 * delay] * [K5 / (reliability + K4)] 
In this case, only the K3 value has a non-zero value. This implies that only delay is taken into consideration to calculate the metric of the shortest path from 172.16.1.0 network to the WAN. The path with the lowest metric, which is delay in this scenario, is the shortest path, and is therefore entered automatically in the routing table. The total delay and the corresponding metric for the three best paths are given as follows:

 

In the given table, the path RA-RB-RE-RI-RK has the lowest metric of 14080. This is the shortest path, so it would be entered in the routing table even if variance were not enabled. In this scenario variance is set to 3, which enables unequal load balancing among those paths that have a metric less than three times the least metric for the given route. Three times the least metric in this scenario is 42240 (14080 x 3). This implies that paths between the 172.16.1.0 network and the WAN having a metric less than 42240 participate in the load balancing. On metric values alone, those paths would appear in the routing tables. However, to be eligible to be a feasible successor the reported distance of the path must be less than the feasible distance (current best path). None of the paths, with the exception of RA-RB-RE-RI-RK meet that requirement. 
The path RA-RB-RD-RH-RK is not entered in the routing table as a result of the unequal load balancing. The scaled EIGRP delay for this path is 43520 (170 x 256), which is more than three times the least metric available from the 172.16.1.0 network to the WAN (42240). In addition, the reported distance for this path is more than the feasible distance. Therefore, the path RA-RB-RD-RH-RK is not used for balancing the load from the 172.16.1.0 network to the WAN and does not appear in the routing tables. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify EIGRP load balancing 
References:
Cisco > Support > Technology Support > IP > IP Routing > Design > Design Technotes > How Does Unequal Cost Path Load Balancing (Variance) Work in IGRP and EIGRP? > Document ID: 13677
Cisco > Support > Technology Support > IP > IP Routing > Design > Design Technotes > How Does Load Balancing Work? > Document ID: 5212
Cisco > Support > Technology Support > IP > IP Routing > Technology Information > Technology Whitepaper > Enhanced Interior Gateway Routing Protocol > Document ID: 16406 > Feasible Distance, Reported Distance, and Feasible Successor




Question 9

OSPF area border routers (ABRs) advertise a default route to stub and totally stubby areas.  
Which command is the BEST command to configure a cost of 25 for the default route advertised to area 1?

  • A: Router(config-router)# area 1 cost 25
  • B: Router(config-router)# area 1 default 25
  • C: Router(config-router)# area 1 default-cost 25
  • D: Router(config-router)# area 1 default-route-cost 25

Correct Answer: C

The correct answer is area 1 default-cost 25. Even though another option (area 1 default 25) is a configurable abbreviation for the command, the more correct answer explicitly specifies the default-cost parameter. The correct syntax for the area default-cost command is shown below:
Router(config-router)# area area-id default-cost cost 
If you have multiple border routers between two areas, you might prefer one exit-point router over the other for that area. By configuring one with a lower cost than the other, it will become the preferred exit point. If that router or its links were to fail, then the routers interior to the area would route through the second-best exit point. You could also set the default costs to values that are close to achieve better load balancing. The default default-cost is 1. Please see the network shown in the graphic. 

 

Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify OSPF path preference 
References:
Cisco IOS Master Command List, Release 12.4 > a through b > area default-cost




Question 10

You need to manually assign IPv6 addresses to the interfaces on an IPv6-enabled router. While assigning addresses, you need to ensure that the addresses participate in neighbor discovery and in stateless auto-configuration process on a physical link. 
Which of the following addresses can be assigned to the interfaces? 

  • A: FEC0:0:0:1::1/64 
  • B: FE80::260:3EFF:FE11:6770/10
  • C: 2001:0410:0:1:0:0:0:1/64
  • D: 2002:500E:2301:1:20D:BDFF:FE99:F559/64

Correct Answer: B

The FE80::260:3EFF:FE11:6770/10 address can be assigned to an interface of the IPv6-enabled router. This address is a link-local address as it has the prefix FE80::/10. Link-local addresses can be configured for an interface either automatically or manually.
Link-local addresses are IPv6 unicast addresses that are configured on the interfaces of an IPv6-enabled router. With link-local addresses, the nodes can connect to a network (local link) and communicate with other nodes. In addition, these addresses participate in the neighbor discovery protocol and the stateless auto-configuration process. 
The FEC0:0:0:1::1/64 address should not be used for the interfaces because this address is a site-local address. Site-local addresses are IPv6 equivalent addresses to IPv4's private address classes. These addresses are available only within a site or an intranet, which typically is made of several network links. 
You should not use the 2001:0410:0:1:0:0:0:1/64 and 2002:500E:2301:1:20D:BDFF:FE99:F559 addresses for the interfaces. These two addresses are global unicast addresses as they fall in the range from 2000::/3 and to E000::/3. A global address is used on links that connect organizations to the Internet service providers (ISPs). 
Objective:
Layer 3 Technologies 
Sub-Objective:
Identify IPv6 addressing and subnetting 
References:
Cisco > Understanding IPv6 Link Local Address










CONNECT US

Facebook

Twitter

PROFEXAM WITH A 20% DISCOUNT

You can buy ProfExam with a 20% discount!



HOW TO OPEN VCEX AND EXAM FILES

Use ProfExam Simulator to open VCEX and EXAM files