Download Cisco.Pass4sure.300-101.v1-0.2017-09-26.1e.90q.vcex

Download Dump

File Info

Exam Implementing Cisco IP Routing (ROUTE v2.0)
Number 300-101
File Name Cisco.Pass4sure.300-101.v1-0.2017-09-26.1e.90q.vcex
Size 4.62 Mb
Posted September 26, 2017
Downloaded 10



How to open VCEX & EXAM Files?

Files with VCEX & EXAM extensions can be opened by ProfExam Simulator.

Purchase

Coupon: MASTEREXAM
With discount: 20%

 
 



Demo Questions

Question 1

Company A recently acquired Company B and the network infrastructures are being merged. Both organizations used non-overlapping globally unique network addressing but different Interior Gateway Protocols (IGPs). Initially, multiple WAN links will connect the two organizations. Company A will maintain its core routing protocol, and Company B's routing protocol will be the edge routing protocol. Two-way redistribution will be used to ensure full network routing capability. What additional routing configuration should be performed to prevent routing loops and suboptimal routing?

  • A: Manually configure static routes.
  • B: Manually configure default routes.
  • C: Manually adjust the administrative distances.
  • D: Manually adjust the local preference attribute.

Correct Answer: C

When routes are being redistributed from the core into the edge and from the edge into the core, the administrative distance (AD) associated with external routes should be modified. This lessens the possibility of sub-optimal routing when multiple routing protocols advertise different paths to the same network. The AD associated with the externally advertised routes should be higher than the internal IGP's AD. To change the AD for an entire routing protocol, use the distance command. An example and the command syntax are shown below:
router(config)#router rip 
router(config-router)#distance 125 
The complete syntax of the distance command is:
distance weight [address mask [ access-list-number | name] 
The weight parameter is the AD, which can be a number from 10 to 255. Note that distances 0 through 9 are reserved for system use. 
To change only the AD for selected networks, use an access list with the distance command as shown below:
router(config)# access-list 5 permit 10.0.0.0 255.0.0.0 
router(config)# access-list 5 permit 11.0.0.0 255.0.0.0 
router(config)# access-list 5 permit 12.0.0.0 255.0.0.0 
router(config)# router rip 
router(config-router)# distance 220 0.0.0.0 255.255.255.255 5 
The 0.0.0.0 255.255.255.255 portion included with the distance command could hold an address/mask combination for a single address, but it is more common to 
use an access list. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify redistribution between any routing protocols or routing sources 
References:
Cisco > Cisco IOS IP Routing: Protocol-Independent Command Reference > distance (ip)
Cisco > Support > Technology Support > IP > IP Routing > Design > Design Technotes > What Is Administrative Distance? > Document ID: 26634




Question 2

Which of the following commands will enable the DHCP and relay services on a Cisco router? 


  • A: RouterA(config)# service dhcp
  • B: RouterA(config)# dhcp enable
  • C: RouterA(config)# enable dhcp
  • D: RouterA(config-if)# dhcp enable
  • E: RouterA(config-if)# service dhcp

Correct Answer: A

Using the service dhcp command at global configuration mode will enable the DHCP and relay services on a Cisco router. By default, these services are already enabled on the router, but they can be disabled using the no service dhcp command. Before the DHCP service can actually function, a pool of addresses must be created and any statically defined addresses (such as the router itself) must be excluded. If the router has two interfaces and needs to issue addresses on both interfaces two pools and two exclusion statements must be present. 
Below is an example of a complete configuration taken from a partial output of the show run command. This router has two interfaces 10.0.0.1/24 and 192.168.5.1/24, creating the need for two pools and two exclusion statements. It excludes the address ranges 10.0.0.1-10.0.0.5 from the 10.0.0.0/24 pool and excludes 192.168.5.1-192.168.5.5 from the 192.168.5.0/24 pool, and creates a pool for 10.0.0./24 and 192.168.5.0/24. 
 
 

The commands RouterA(config)# dhcp enable and RouterA(config)# enable dhcp are incorrect because the syntax is incorrect. 
The command RouterA(config-if)# dhcp enable is incorrect because the syntax is incorrect and because it is executed in interface configuration mode. Enabling DHCP is done at the global prompt. 
The command RouterA(config-if)# service dhcp is incorrect because it is executed in interface configuration mode. Enabling DHCP is done at the global prompt 
Objective:
Layer 3 Technologies 
Sub-Objective:
Identify, configure, and verify IPv4 addressing and subnetting 
References:
Cisco > IP Addressing: DHCP Configuration Guide, Release 15M&T > DHCP Overview
Cisco > Cisco IOS IP Addressing Services Command Reference > service dhcp




Question 3

You are configuring a DHCP server to service a group of clients that are located on a different subnet than the DHCP server itself. What else must you configure to ensure a successful setup?

  • A: Relay agent
  • B: Multicast routing
  • C: Unicast routing
  • D: Access list

Correct Answer: A

If a DHCP server needs to service clients in a different subnet, you will need to configure a relay agent. The relay agent service is enable by default but does not function unless you provide the IP address of the remote DHCP server, which is done by executing the ip helper address command on the interface where the address needs to be announced. 
The fact that the clients are on a different subnet indicates that there is a router between the DHCP server and the clients. The DHCP discover packet that a client sends out is in the form of a broadcast. Routers do not forward broadcast traffic from one segment to the other. Without a relay agent, the DHCP server would never receive the requests. 
A relay agent resides on the same segment as the clients. When a client sends out a discover packet, the relay agent takes the request, converts it to a unicast packet, and forwards the request to the DHCP server on the other network segment. 
The relay agent can also be activated on the router that separates the two network segments. To enable the relay agent service on a Cisco router where 172.16.10.2 is the IP address of the DHCP server, use the following command:
Router(config-if)# ip helper-address 172.16.10.2 
A relay agent can also be used to assist in the auto configuration of a switch. Auto configuration is a process whereby:
A switch boots up. 
The switch obtains an IP address, subnet mask, and gateway address (optional). 
The switch uses the DNS server to locate the TFTP server. 
The switch connects to the TFTP server, downloads the configuration file, and applies it.  
When the switch must broadcast to locate the DHCP, DNS, or TFTP server, IP helper addresses can be provided for all of these. When the switch broadcasts, a unicast will be sent to all of these addresses. 
In following illustration, the FastEthernet0 interface of the router is connected to the subnet containing the switch and the FastEthernet1 interface of the router is connected to the subnet containing the DHCP, DNS, and TFTP servers. The addresses involved are:
Switch - 10.2.2.2 
Router - F0 10.2.21, F2 20.2.2.2 
DHCP - 20.2.2.5 
DNS - 20.2.2.6 
TFTP - 20.2.2.7  
The router that is located between the subnet containing the switch and the subnet containing the DHCP, DNS, and TFTP servers should be configured as shown below:
 
 

Regardless of whether the ip helper-address command has been used to aid in the DHCP configuration of a switch utilizing auto configuration, or to aid DHCP clients in a different subnet from the DHCP server, the DHCP relay service will provide relay services for the following UDP protocols by default:
Trivial File Transfer Protocol (TFTP) (port 69) 
Domain Naming System (DNS) (port 53) 
Time service (port 37) 
NetBIOS Name Server (port 137) 
NetBIOS Datagram Server (port 138) 
Boot Protocol (BOOTP) client and server packets (ports 67 and 68) 
TACACS service (port 49) 
IEN-116 Name Service (port 42)  
This default behavior can be altered with the IP forward-protocol udp command executed in global configuration mode. 
Multicast routing, unicast routing and access lists do not aid in the DHCP communication process. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Identify, configure, and verify IPv4 addressing and subnetting 
References:
Cisco > IP Addressing: DHCP Configuration Guide > Configuring the Cisco IOS DHCP Relay Agent




Question 4

You have two autonomous systems connected by more than one ASBR.  
Which strategy does Cisco recommend in this situation?

  • A: Use two-way redistribution.
  • B: Use a default route in both directions.
  • C: Allow routes to be exchanged in one direction, and use a default route in the other direction.
  • D: Manually configure routes in all ASBRs, and update the configuration each time there is a change in either AS.

Correct Answer: C

If there is a single autonomous system border router (ASBR) connecting two autonomous systems (AS), Cisco generally recommends full two-way route redistribution. But when there are multiple ASBRs, as in this scenario, two-way route redistribution may result in routing loops. One solution is to use a default route in one direction and allow routes to be exchanged in the other direction. 
Default routes in both directions will almost certainly cause routing loops. 
Manual configuration of static routes would work, but the administrative maintenance necessary when there are changes would be considerable. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify redistribution between any routing protocols or routing sources 
References:
Cisco > Home > Support > Technology Support > IP Routing > Technology Information > Technology White Paper > OSPF Design Guide > OSPF Design Tips




Question 5

Which command can you use to verify that interfaces have been configured in the correct areas and to show timer intervals and neighbor adjacencies for OSPF?

  • A: show ip ospf
  • B: show ip route
  • C: show ip protocol
  • D: show ip ospf database
  • E: show ip ospf interface

Correct Answer: E

The correct answer is show ip ospf interface. This command displays all of the important OSPF parameters that relate to each of the interfaces. Information can be displayed on a per-interface basis if an interface is specified. If none is specified, all interfaces running OSPF will be displayed. 
 
 

The following commands can be used to monitor and verify OSPF operation:
show ip ospf - displays the number of times the SPF algorithm has run and the default LSU interval, but does not show neighbor adjacencies. 
show ip route - displays known routes and how they were discovered, but not timers and neighbor adjacencies. 
show ip protocol - displays information about timers, filters, metric, etc. for the entire router, but not OSPF neighbor adjacencies. 
show ip ospf database - displays the router ID, the OSPF process ID, and the contents of the topological database, but not adjacencies information or timer 
values.  
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify OSPF neighbor relationship and authentication 
References:
Cisco > Cisco IOS IP Routing: OSPF Command Reference > show ip ospf interface




Question 6

Refer to the following table:
 

 
Path1, Path2, and Path3 are the available routes between routers A and B. The bgp always-compare med command is executed for all three routes. 
What should be the value for the missing ASN (represented by a question mark in the table) so that Path3 becomes the best path between routers A and B based on their MED values?

  • A: 10
  • B: 20
  • C: 30
  • D: 40

Correct Answer: D

The missing autonomous system number (ASN) in the AS_PATH parameter of Path3 should be 40 so that Path3 becomes the best path from A to B. BGP selects the best path by first selecting the first valid path between two routers. If other paths are available between the two routers, BGP compares values of various attributes to select the best available path. In this case, Path 2 is the current best path between routers A and B. The values of various parameters (listed in the table) are compared with Path1 and Path2. 
While comparing Path1 and Path2, the weight, LOCAL_PREF, local originate source command, length of AS_PATH, and origin type are same. Therefore, these parameters are not useful in determining the best path. However, the MED value of Path2 is lower than that of Path1. As a result, Path2 is selected as the best path because BGP prefers the route with the lesser MED value. 
BGP now compares the parameter values of Path 2 (the current best path) and Path3. The weight and LOCAL_PREF parameters are same for both routes. Path 2 and Path3 are both local routes originated by using the redistribute and the network commands, respectively. BGP prefers local routes learned by the network or redistribute commands over those that are learned by the aggregate-address command. 
The AS_PATH parameter specifies the list of AS numbers that comprise the route. The best path should have the shortest value for the AS_PATH parameter. In this case, both Path2 and Path3 consist of three AS numbers and are originated by an IGP. Therefore, the AS_PATH and the origin type parameters are not helpful in determining the best path. 
Finally, BGP compares the MED values of Path2 and Path3. The MED values are compared only when the first AS number in the AS_PATH is the same for both routes; that is, when both routes begin in the same AS. The first ASN in the AS_PATH parameter of Path2 is 40; therefore, the missing ASN for Path3 should be 40. 
This allows the comparison of MED values and the selection of Path3 as the best route as it has lower MED value. 
All the other options are incorrect because a value other than 40 disables the comparison of the MED values between Path2 and Path3. If the MED value is not considered, then BGP determines whether Path3 is an iBGP or eBGP router. BGP selects an iBGP route instead of an eBGP route. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Explain BGP attributes and best-path selection 
References:
Internetworking Technology Handbook > BGP > BGP attributes




Question 7

Refer to the following exhibit that shows four Cisco routers named rtr1, rtr2, rtr3, and rtr4: 
 

 
The routers rtr2, rtr3, and rtr4 are eBGP peers of rtr1. In addition, rtr3 and rtr4 are also eBGP peers. 
You want to implement the following requirements on rtr1:
The first attribute to select the best path is used. 
Advertisements about 10.77.22.0/24 sent by rtr4 will be chosen over the advertisements sent by rtr3.  
Which of the following commands should be included in the implementation plan for rtr1 to achieve the desired results? (Each option is a part of the solution. Choose all that apply.) 

  • A: neighbor 135.90.66.1 route-map set_weight out
  • B: neighbor 135.90.66.6 route-map set_weight in
  • C: route-map set_weight deny 10
  • D: match ip-address 1
  • E: set metric 100
  • F: set weight 100

Correct Answer: BDF

The following commands should be included in the implementation plan:
neighbor 135.90.66.6 route-map set_weight in 
match ip-address 1 
set weight 100 
The neighbor 135.90.66.6 route-map set_weight in command specifies a route-map named set_weight for the incoming routing updates from 135.90.66.6 peer. The match ip-address 1 command specifies a criterion to match the IP address as specified in an access list. When the match criterion is met, the action specified in the set weight command is performed. 
The set weight 100 command sets the weight attribute, which is a Cisco-defined attribute, to 100. The weight attribute is the first to be checked when BGP selects the best path between eBGP routers. This attribute is local to the router on which it is set and cannot be advertised to other routers. 
The complete set of commands to achieve the desired results is as follows:
access-list 1 permit 10.77.22.0 0.0.0.255 
router bgp 444 
neighbor 135.90.66.3 remote-as 111 
neighbor 135.90.66.1 remote-as 222 
neighbor 135.90.66.6 remote-as 333 
neighbor 135.90.66.6 route-map set_weight in 
route-map set_weight permit 10 
match ip-address 1 
set weight 100 
The set metric 100 command should not be included in the implementation plan to achieve the desired results. This command sets the metric to 100; however, the requirement is to use the first attribute to be checked, which is the weight attribute. 
The neighbor 135.90.66.1 route-map set_weight out command should not be included in the implementation plan. This command forms an eBGP neighbor relationship with rtr3. The command also uses a route map named set_weight to set the weight attribute for the routes sent by rtr1. However, the weight attribute is local to rtr1 and cannot be set for outbound routes. 
The route-map set_weight deny 10 command should not be specified in the implementation plan to achieve the desired results. This command creates a route map named set_weight. The deny keyword in this command indicates that if the match criterion is satisfied, then the set action is not performed. The permit keyword should be specified instead of the deny keyword to perform the set action when a match occurs. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Identify suboptimal routing 
References:
Cisco > Support > Technology Support > IP > IP Routing > Design > Design Technotes > BGP Case Studies > BGP Case Studies 1 > Route Maps 
Cisco > Support > Technology Support > IP > IP Routing > Design > Design Technotes > BGP Best Path Selection Algorithm 
Cisco > Support > Technology Support > IP > IP Routing > Design > Design Technotes > BGP Case Studies > BGP Case Studies 2 > Weight Attribute




Question 8

Examine the exhibit. 
 

 
You have determined that RTR2 is not advertising the CIDR summary address 192.168.0.0 to the other routers in AS 65100. Which set of configuration commands will enable the BGP router RTR2 to announce the network prefix 192.168.0.0/16 to the other routers in the AS 65100?

  • A: router bgp 65100 
    neighbor 172.16.1.2 remote-as 65100 
    neighbor 192.168.3.2 remote-as 65100 
    network 192.168.3.0
  • B: router bgp 65100 
    neighbor 172.16.1.2 remote-as 65101 
    neighbor 192.168.3.2 remote-as 65100 
    network 192.168.0.0
  • C: router bgp 65100 
    neighbor 172.16.1.2 remote-as 65100 
    neighbor 192.168.3.2 remote-as 65100 
    network 192.168.0.0 mask 255.255.0.0 
    ip route 192.0.0.0 255.0.0.0 null 0
  • D: router bgp 65100 
    neighbor 172.16.1.2 remote-as 65101 
    neighbor 192.168.3.2 remote-as 65100 
    network 192.168.0.0 mask 255.255.0.0 
    ip route 192.168.0.0 255.255.0.0 null 0

Correct Answer: D

Issuing the following commands will cause RTR2 to advertise the CIDR block 192.168.0.0/16 to the other routers by using BGP:
RTR2(config)# router bgp 65100 
RTR2(config-router)# neighbor 172.16.1.2 remote-as 65101 
RTR2(config-router)# neighbor 192.168.3.2 remote-as 65100 
RTR2(config-router)# network 192.168.0.0 mask 255.255.0.0 
RTR2(config-router)# ip route 192.168.0.0 255.255.0.0 null 0 
The network command specifies the address that will be inserted into the BGP table. Without the mask keyword, the classful network will be assumed. Because 255.255.0.0, or /16, is not the natural mask for any Class C address, the mask keyword must also be specified. Thus, 192.168.0.0 and 255.255.0.0 identify the desired address and mask of the 192.168.0.0/16 network prefix. 
The router checks the IP forwarding table for an exact match before it advertises the route. Without a matching entry in the IP forwarding table, that route will not be advertised. RTR2 must be able to advertise a CIDR block and not the individual subnets. A static route is required because BGP requires that a match of the network prefix be present in the forwarding table when using the network command with the mask keyword. Therefore, to ensure an exact match for the identified prefix exists in the IP forwarding table, and to ensure that the prefix will always be advertised, a static route for 192.168.0.0/16 to null 0 is also required. 
The syntax for the network command is shown below:
network network-number [ mask network-mask ] [ route-map map-tag ] 
The parameters are:
mask - This parameter is optional and identifies the network or subnetwork to advertise. 
route-map - This parameter is optional and identifies a preconfigured route-map that will be used to filter specific addresses from being advertised.  
The following command set is missing the mask keyword in the network command and the command to create a static route to null 0. The address used in the network command is also incorrect. It should 192.168.0.0:
router bgp 65100 
neighbor 172.16.1.2 remote-as 65100 
neighbor 192.168.3.2 remote-as 65100 
network 192.168.3.0 
The following command set is missing the mask keyword in the network command and the command to create a static route to null 0:
router bgp 65100 
neighbor 172.16.1.2 remote-as 65101 
neighbor 192.168.3.2 remote-as 65100 
network 192.168.0.0 
The following command set uses an incorrect mask (255.0.0.0) in the command that creates the static route to null 0. It should be 255.255.0.0:
router bgp 65100 
neighbor 172.16.1.2 remote-as 65100 
neighbor 192.168.3.2 remote-as 65100 
network 192.168.0.0 mask 255.255.0.0 
ip route 192.0.0.0 255.0.0.0 null 0 
Objective:
Layer 3 Technologies 
Sub-Objective:
Describe, configure, and verify BGP peer relationships and authentication 
References:
Internetworking Case Studies > Using the Border Gateway Protocol for Interdomain Routing > Controlling the Flow of BGP Updates > CIDR and Aggregate Addresses > Aggregation and Static Routes




Question 9

Which method of advertising networks from an autonomous system into BGP can result in the most instability? 


  • A: Using the network command
  • B: Redistributing static routes into BGP
  • C: Redistributing dynamic routes into BGP
  • D: Redistributing static routes into IBGP

Correct Answer: C

Redistributing dynamic IGP routes into BGP can result in instability, and is not recommended. 
Dynamic routes can disappear from the routing table, and even flap up and down constantly if there are link problems, especially with WAN links. If the networks are redistributed into BGP, their flapping can result in BGP updates about the route changing status, resulting in instability for BGP. 
Most ISPs guard against unstable routes and might threaten to cut off your BGP connectivity if you have flapping routes that cause BGP instability in their networks. 
The network command and redistributed static routes, on the other hand, tend not to change state so often. As a result, they are considered much more stable from a BGP perspective. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Configure and verify manual and autosummarization with any routing protocol 
References:
Cisco > Support > Technology Support > IP > IP Routing > Design > Design Technotes > BGP Case Studies > Document ID: 26634 > Redistribution




Question 10

Consider the following output of the show ip bgp summary command:
 

 
Which of the following neighbors have an established connection with RouterA?

  • A: 10.1.1.1
  • B: 10.2.1.1
  • C: 10.3.1.1
  • D: 10.4.1.1
  • E: 10.5.1.1

Correct Answer: B

The neighbor with the IP address 10.2.1.1 has an established connection with RouterA. This is because the State/PfxRcd value for this neighbor is a number, 15, which indicates the number of prefixes received by RouterA from the neighbor. The prefixes are exchanged between BGP neighbors through the update message, which can be transmitted only if an established connection exists between the neighbors. An established connection exists between two neighbors if the local router is in Open Confirm state and it receives a KEEPALIVE or an UPDATE message. 
The connection between RouterA and the neighbor with the IP address 10.1.1.1 is not established. This is because the State/PfxRcd value for this neighbor is OPENSENT. In this state, RouterA sends an OPEN message to a neighbor to determine the parameters for establishing a connection. The OPENSENT state occurs before the connection is established. 
The connection between RouterA and the neighbor with the IP address 10.3.1.1 is not established. This is because the State/PfxRcd value for this neighbor is IDLE. 
In this state, RouterA does not accept any incoming connections from the neighbor. 
The connection between RouterA and the neighbor with the IP address 10.4.1.1 is not established. This is because the State/PfxRcd value for this neighbor is ACTIVE. In this state, RouterA is attempting to establish a BGP peering session but it is not yet complete. 
The connection between RouterA and the neighbor with the IP address 10.5.1.1 is not established. This is because the State/PfxRcd value for this neighbor is OPENCONFIRM. In this state, RouterA waits for a KEEPALIVE or NOTIFICATION message from the neighbor. 
Objective:
Layer 3 Technologies 
Sub-Objective:
Describe, configure, and verify BGP peer relationships and authentication 
References:
Cisco IOS IP Routing: BGP Command Reference > show ip bgp summary










CONNECT US

Facebook

Twitter

PROFEXAM WITH A 20% DISCOUNT

You can buy ProfExam with a 20% discount!



HOW TO OPEN VCEX AND EXAM FILES

Use ProfExam Simulator to open VCEX and EXAM files