Download Implementing Cisco Enterprise Advanced Routing and Services (300-410 ENARSI).PrepDumps.300-410.2021-06-30.1e.190q.vcex

Download Exam

File Info

Exam Implementing Cisco Enterprise Advanced Routing and Services (300-410 ENARSI)
Number 300-410
File Name Implementing Cisco Enterprise Advanced Routing and Services (300-410 ENARSI).PrepDumps.300-410.2021-06-30.1e.190q.vcex
Size 9.08 Mb
Posted June 30, 2021
Downloads 31
Download Implementing Cisco Enterprise Advanced Routing and Services (300-410 ENARSI).PrepDumps.300-410.2021-06-30.1e.190q.vcex

How to open VCEX & EXAM Files?

Files with VCEX & EXAM extensions can be opened by ProfExam Simulator.

Purchase

Coupon: MASTEREXAM
With discount: 20%



 
 



Demo Questions

Question 1

Automatic 6-to-4 tunnels exist between dual-stack routers (A, B, and C). One router has the IPv6 address, 2002:D030:6BC0:173C::26:37D0/48
Which of the following addresses is the IPv4 address of the router with the IPv6 address 2002:D030:6BC0:173C::26:37D0/48?

  • A: 10.176.15.131
  • B: 10.200.80.67
  • C: 208.48.107.192
  • D: 208.138.16.110

Correct Answer: C

The IPv4 address of the IPv6 router is 208.48.107.192. In an automatic 6-to-4 tunnel, IPv6 addresses have the 2002::/16 prefix. The 32-bit IPv4 address of the IPv6 router is then embedded into the IPv6 address. The 32  bits of the IPv4 address is embedded in the second and third quartet of the IPv6 address. The second and third quarters in the IPv6 address correspond to D030:6BC0. The conversion of these hexadecimal digits into decimal is given as follows:

    

The IPv6 router does not have 10.176.15.131 as its IPv4 address. The 10.176.15.131 address is the IPv4 equivalent of the second and third quarter (05B0:0F81) in the source IPv6 address.
The other two IPv4 addresses are incorrect as they pertain to neither of the two IPv6 hosts. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Cisco IOS IPv6 Implementation Guide > Implementing Tunneling for IPv6




Question 2

You have recently joined a company as the network administrator. You have been asked to complete the configuration on the border routers for an automatic 6-to-4 tunnel between several IPv6 network domains. The commands that are currently configured on the routers are as follows:
ipv6 route tunnel 
interface tunnel 
ipv6 address 
tunnel source 
Which of the following additional commands is required to complete the configuration of automatic 6-to-4 tunnel on the border routers?

  • A: tunnel mode ipv6ip
  • B: tunnel mode ipv6ip 6to4
  • C: tunnel mode ipv6ip auto-tunnel
  • D: tunnel mode ipv6ip isatap

Correct Answer: B

The correct answer is to use the tunnel mode ipv6ip 6to4 command to complete the configuration of an automatic 6-to-4 tunnel. This command requires the use of IPv6 unicast addresses that have the 2002::/16 prefix. 
The types of tunneling mechanisms supported by IPv6 are:
Automatic 6-to-4 tunnel 
ISATAP tunnel 
Manually configured tunnel 
GRE tunnel  
Apart from using a tunneling mechanism, interoperability between IPv4 and IPv6 can be provided by using a dual-stack infrastructure or Network Address Translation-Protocol Translation (NAT-PT). A dual-stack infrastructure allows you to use both IPv4 and IPv6 addresses on the same router/host. NAT-PT is used to translate IPv4 addresses to IPv6 and vice versa. 
The tunnel mode ipv6ip command should not be used to complete the configuration because this command specifies IPv6 as the passenger protocol and creates a manually configured tunnel. 
The tunnel mode ipv6ip auto-tunnel command is not required to enable automatic 6-to-4 tunneling on the border routers. This command creates an automatic IPv4-compatible IPv6 tunnel between the routers. 
The tunnel mode ipv6ip isatap command should not be used because this command creates an ISATAP tunnel. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Cisco IOS IPv6 Configuration Guide; Implementing Tunneling for IPv6 > Configuring Manual IPv6 Tunnels 
Cisco > Cisco IOS IPv6 Command Reference > tunnel mode ipv6ip




Question 3

You have implemented IPv6 automatic 6-to-4 tunneling between three IPv6 subnets as shown in the network exhibit. (Click the Exhibit(s) button.) 

    

You have used the following commands to implement the automatic 6-to-4 tunnel:

    

Your supervisor has assigned the task of verifying the automatic 6-to-4 tunnel to one of your colleagues. Your colleague runs the show running-config command and finds that incorrect IPv6 addresses have been assigned to the tunnel interfaces of the routers. 
Which of the following IPv6 addresses should be assigned to rectify the problem? (Choose two.)

  • A: 2002::c0a8:2d01/64 to the Fa0/1 interface of rtrA
  • B: 2002:c0a8:4b01::1/64 to the Fa0/1 interface of rtrB
  • C: 2002:c0a8:7d01::1/64 to the Fa0/1 interface of rtrC
  • D: 2002:c0a8:4b01::1/64 to the Fa0/1 interface of rtrA 

Correct Answer: BC

The 2002:c0a8:4b01::1/64 and the 2002:c0a8:7d01::1/64 IPv6 addresses should be assigned to the Fa0/1interfaces of rtrB and rtrC, respectively. Automatic 6-to-4 tunnels embed the IPv4 address of the tunnel interfaces into the second and third quartets of the IPv6 address that has the 2002::/16 prefix.
To assign IPv6 addresses to the tunnel interfaces, perform the following steps:
1.Convert the IPv4 address of the tunnel interface into binary. 
2.Convert the binary equivalent of the IPv4 address into hexadecimal (IPv6). 
3.Append the hexadecimal equivalent to the 2002::/16 prefix to form the IPv6 prefix of the tunnel interface. 
For the Fa0/1 interface of rtrB, its IPv4 address of 192.68.75.1 is equivalent to the IPv6 address c0a8:4b01.
This address is then appended to the 2002::/16 prefix, resulting in 2002:c0a8:4b01::/48. The remaining host bits can be filled with zeros. Similarly, the IPv4 address of the Fa0/1 interface of rtrC is converted to the IPv6 address 2002:c0a8:7d01::/48.
The 2002::c0a8:2d01/64 IPv6 address should not be assigned to the Fa0/1 interface of rtrA. The Fa0/1 interface of rtrA has the IPv4 address 192.168.45.1. The IPv6 equivalent of the IPv4 address, which is c0a8:2d01, should be embedded in the second and third quartets of the IPv6 address instead of the seventh and eighth quartets. IPv4 addresses are embedded into the last 32 bits for ISATAP tunnels. 
The 2002:c0a8:4b01::1/64 IPv6 addresses should not be assigned to the Fa0/1 interface of rtrA. This IPv6 address is the equivalent of the IPv4 address 192.168.75.1, which is the address of the Fa0/2 interface of rtrB and not rtrA. Therefore, this IPv6 address should be assigned to the Fa0/1 interface of rtrB. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Cisco Press > Articles > Cisco Certification > CCNP > CCNP Self-Study: Advanced IP Addressing
Cisco Press > Articles > Network Technology > General Networking > Cisco Self-Study: Implementing Cisco
IPv6 Networks (IPV6) 
Cisco > Support > Technology Support > IP > IP Version 6 (IPV6) > Configure > Configuration Examples and Technotes > IPv6 Tunnel Through an IPv4 Network 
Cisco IOS IPv6 Implementation Guide, Release 15.2M&T > Implementing Tunneling for IPv6




Question 4

An automatic IPv4-compatible IPv6 tunnel exists between two IPv6 networks. The two IPv6 networks belong to different BGP autonomous systems (AS). The tunnel source has the IPv4 address 172.168.111.65/24 and the tunnel destination has the IPv4 address 172.168.222.80/24. 
Which of the following statements is TRUE about the tunnel source and tunnel destination IPv6 addresses? (Choose two.)

  • A: the IPv6 address of the tunnel source is 172.168.111.65::
  • B: the IPv6 address of the tunnel source is ::172.168.111.65
  • C: the IPv6 address of the tunnel destination is 172.168.222.80::
  • D: the IPv6 address of the tunnel destination is ::172.168.222.80

Correct Answer: BD

The IPv6 address of the tunnel source is ::172.168.111.65 and the IPv6 address of the tunnel destination is ::172.168.222.80. These two addresses are IPv4-compatible IPv6 addresses, which are addresses that contain the IPv4 addresses of the tunnel source and destination. 
In automatic IPv4-compatible IPv6 tunnel, the IPv4 addresses of the tunnel source and the tunnel destination are used to determine their IPv6 addresses. The IPv4 addresses of the tunnel source/destination are embedded into the least significant 32 bits of an all-zero unicast IPv6 address. The resultant IPv6 address has zeros in the most significant 96 bits and the IPv4 address of the tunnel source/destination in the remaining 32 bits. 
In this case, the source of an automatic IPv4-compatible IPv6 tunnel has the IPv6 address 0:0:0:0:0:0:172.168.111.65, abbreviated as ::2.168.111.65. You can also convert this address into pure hexadecimal format, which would be ACA8:6F41.
Any of the following three addresses could be used to identify the BGP neighbor at 172.168.11.65:
0:0:0:0:0:0:172.168.111.65
::172.168.111.65
::ACA8:6F41
Similarly, the tunnel destination has the IPv6 address 0:0:0:0:0:0:172.168.222.80 (abbreviated as ::172.168.222.80). The hexadecimal form of the IPv6 address of the tunnel destination is ::ACA8:DE50.
Any of the following three addresses could be used to identify the BGP neighbor at 172.168.222.80:
0:0:0:0:0:0:172.168.222.80
::172.168.222.80
::ACA8:DE50
The other two options state incorrect IPv6 addresses of the tunnel source and the tunnel destination. Both options specify an IPv6 address that has the IPv4 address of the tunnel source/destination in the most significant 32 bits and zeros in the least significant 96 bits. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Home > Support > Technology Support > IP > IP Version 6 (IPv6) > Configure > Configuration Examples and Technotes > IPv6 Tunnel Through an IPv4 Network > Configure > Configurations (Automatic IPv4-Compatible Mode) 
Cisco IOS IPv6 Implementation Guide > Implementing Tunneling for IPv6 
Cisco > Support > Technology Support > IP > IP Version 6 (IPv6) > Technology Information > Technology 
White Paper > IPv6 Deployment Strategies > Selecting a Deployment Strategy > Deploying IPv6 Over IPv4Tunnels > Automatic IPv4-Compatible Tunnel




Question 5

Your company has implemented IPv6 addresses and routing on every host, server, and router. Recently, your company acquired another company that has an IPv4 addressing scheme for its entire network. The acquired company's network does not have any support for IPv6. You need to devise a method so that the IPv6 hosts in your company can seamlessly communicate with the IPv4 hosts of the acquired company's network. You do not want to install any additional routers, and you want minimum configuration changes on the networks. Which of the following is the best method to allow communication between the IPv4 and IPv6 hosts?

  • A: Embedding IPv6 packets into IPv4 packets 
  • B: Translating IPv4 addresses to and from IPv6 addresses
  • C: Configuring IPv6 on the hosts and routers in the IPv4 network
  • D: ConfiguringIPv4 on the hosts and routers in the IPv6 network

Correct Answer: B

Translating IPv4 addresses to and from IPv6 addresses is the best method to allow communication between the IPv4 and IPv6 hosts. This translation of IPv4 and IPv6 addresses is known as Network Address Translation-Protocol Translation (NAT-PT). NAT-PT is a technique available for deploying IPv6 and IPv4 addresses in a unified network. With NAT-PT, the network requires fewer modifications and software for the IPv4 and IPv6 hosts. Additionally, it provides easy and quick interoperability between the IPv4 and IPv6 hosts. 
NAT-PT is configured on one of the routers on the border of the IPv4 and IPv6 networks. Whenever an IPv4 packet intended for a host in the IPv6 network is received by the NAT-PT router, the router applies NAT-PT on the packet and translates all the headers in the IPv4 headers. In addition, it translates the IPv4 source and destination addresses to IPv6 source and destination addresses. The IPv6 packet is then set by the NAT-PT router to the intended IPv6 host. The NAT-PT router performs the reverse translation when an IPv6 host sends a packet to an IPv4 host. 
Embedding IPv6 packets into IPv4 packets is not the best method to allow communication between the IPv4 and IPv6 hosts. When IPv6 packets are embedded inside IPv4 packets, the process is referred to as tunneling. 
Tunneling is appropriate when two IPv6 networks are separated by an IPv4 network. When an IPv6 host of one network sends an IPv6 packet destined for a host on the other IPv6 network, an IPv4 tunnel is created between the two IPv6 networks. The IPv6 packet is then embedded into an IPv4 packet that traverses through the IPv4 tunnel to reach the intended IPv6 host, where the embedded packet is extracted by the recipient. In this scenario, a single IPv6 network is available; hence, a tunnel cannot be formed. 
Configuring IPv6 on the hosts and routers in the IPv4 network, or configuring IPv4 on the hosts and routers in the IPv6 network, are not the best methods to allow communication between the IPv4 and IPv6 hosts. Each of these two methods is cumbersome and not the most efficient for providing interoperability between IPv4 and IPv6 in this case. Furthermore, the IPv4 hosts on the acquired company's network do not support IPv6 as stated. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Cisco NAT Configuration Guide, Release 15M&T > NAT-PT for IPv6




Question 6

You have implemented an automatic 6-to-4 tunnel between the routers rtrA and rtrB as shown in the following network diagram:

    

The routers rtrA and rtrB are connected to two IPv6 subnets and are separated by an IPv4 network. You decide to verify whether the tunnel was correctly implemented using the show running-config command. 
Which of the following commands should exist in the output of the show running-config command on rtrA and rtrB? (Choose all that apply.)

  • A: interface tunnel
  • B: tunnel source
  • C: tunnel destination
  • D: tunnel mode ipv6ip
  • E: tunnel mode ipv6ip 6to4

Correct Answer: ABE

The following commands should exist in the output of the show running-config command on rtrA and rtrB:
interface tunnel 
tunnel source 
tunnel mode ipv6ip 6to4 
The interface tunnel command is used to define a tunnel interface on the router. The tunnel source command allows you to specify the source of the tunnel, which is the router interface that faces the IPv4 network. The tunnel source must be configured with an IPv4 address. The tunnel mode ipv6ip 6to4 command is used to specify the tunneling mechanism, which in this case is automatic 6-to-4. 
The partial output of the show running-config command on rtrA is as follows:

interface Tunnel0 
no ip address 
tunnel mode ipv6ip 6to4 
tunnel source 172.50.20.5 
ipv6 address 2002:ac32:of06::1/48

<output omitted> 
The partial output of the show running-config command on rtrB is as follows:

interface Tunnel0 
no ip address 
tunnel mode ipv6ip 6to4 
tunnel source 172.50.20.1 
ipv6 address 2002:ac32:0f06::2/48

<output omitted> 
The tunnel destination command and the tunnel mode ipv6ip commands do not appear in the show running-config output when automatic 6-to-4 tunnels are implemented on rtrA and rtrB. Both of these commands are executed for manually configured tunnels. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Cisco Press > Articles > Cisco Certification > CCNP > CCNP Self-Study: Advanced IP Addressing
Cisco Interface and Hardware Component Configuration Guide > IPv6 Automatic 6to4 Tunnels 
Cisco > Support > Technology Support > IP > IP Version 6 (IPV6) > Configure > Configuration Examples and Technotes > IPv6 Tunnel Through an IPv4 Network 
Cisco IOS IPv6 Implementation Guide > Implementing Tunneling for IPv6




Question 7

Which of the following statements are TRUE about manually configured IPV4-to-IP6 tunnels and GRE tunnels? 
(Choose two.)

  • A: Manually configured tunnels use the tunnel mode ipv6ip command, while GRE tunnels use the tunnel mode gre ip command.
  • B: Manually configured tunnels support IPv6 IGPs, while GRE tunnels do not.
  • C: Manually configured tunnels block IPv6 multicasts, while GRE forwards them.
  • D: Manually configured tunnels do not support multiple passenger protocols, while GRE tunnels support them.

Correct Answer: AD

The following statements are TRUE about manually configured tunnels and GRE tunnels:
Manually configured tunnels use the tunnel mode ipv6ip command, while GRE tunnels use the tunnel mode gre ip command. 
Manually configured tunnels do not support multiple passenger protocols, while GRE tunnels support them.  
Manually configured tunnels and Generic Routing Encapsulation (GRE) tunnels are static point-to-point tunneling methods. Both of these tunneling methods provide a permanent link between two IPv6 networks that are separated by an IPv4 backbone. For each link between two IPv6 networks, a separate tunnel needs to be created. 
Manually configured tunnels use a particular passenger protocol and do not support multiple passenger protocols at the same time. However, GRE tunnels can simultaneously use various passenger protocols. 
It is incorrect to state that manually configured tunnels support IPv6 IGPs, while GRE tunnels do not. GRE tunnels also support IPv6 IGPs, such as OSPF, RIP, and IS-IS. 
It is incorrect to state that manually configured tunnels block IPv6 multicasts, while GRE forwards them. 
Manually configured tunnels also forward IPv6 multicasts. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Cisco IOS IPv6 Configuration Guide, Release 12.4 > Implementing Tunneling for IPv6 > Configuration 
Examples for Implementing Tunneling for IPv6 > Example: Configuring Manual IPv6 Tunnels




Question 8

Which dialer interface command sets the maximum size of IP packets to 1492?

  • A: router(config-if)# mtu 1492
  • B: router(config-if)# ip ppp 1492
  • C: router(config-if)# ip 1492 
  • D: router(config-if)# ip mtu 1492

Correct Answer: D

The correct interface command to set the maximum size of IP packets (maximum transmission unit or MTU size) to 1492 is router(config-if)# ip mtu 1492. This command is required because RFC 2516 states the maximum receive unit (MRU) must not be negotiated larger than 1492 bytes. 
All other answers are invalid commands due to incorrect syntax. 
Objective:
Network Principles 
Sub-Objective:
Explain TCP operations 
References:
Cisco > Cisco IOS IP Application Services Command Reference > idle (firewall farm datagram protocol)through ip slb natpool > ip mtu




Question 9

Examine the following FIB table:

    

Which of the following statements is NOT true?

  • A: These are the default entries in an FIB table
  • B: No IP addresses have been configured on this router
  • C: Multicast routing is enabled
  • D: The gateway of last resort has not been set

Correct Answer: C

The Forwarding Information Base (FIB) table is created when Cisco Express Forwarding (CEF) is enabled on the router. FIB is a mapping of destination networks and IP addresses to next-hop IP addresses and exit interfaces. 
In the scenario, multicast routing has NOT enabled in the router. If it were enabled, the next hop for the 224.0.0.0/4 network would not be listed as drop. A drop means any packets sent to multicast IP addresses will be dropped. If multicast routing were enabled, the entry for 224.0.0.0 would appear as follows:
Prefix             Next Hop                Interface 
224.0.0.0/4        0.0.0.0 
The next hop of 0.0.0.0 means that this traffic will be process switched, and CEF cannot forward the packets. 
The table displayed in the scenario contains the default entries in the FIB. These entries will change based on further configuration of the router interfaces and the addition of routes to the routing table through either static routing or through routing protocols. 
No IP addresses have been configured on the router. Had they been configured, the addresses of the networks to which they were connected would be in the table. For example, if the IP address of the FastEthernet 0/1 interface were set to 192.168.1.1/24, three entries would have been added to the table as follows:

    

While the first IP address represents the directly attached network of which the interface is a member, the second IP address represents the network ID of the network, the third IP address represents the specific IP address assigned to the interface, and the last IP address represents the broadcast address of the network. 
The gateway of last resort has not been set on the router. If it were set, it would be listed along with an IP address for the next hop and the exit interface. An entry for a gateway of last resort (or default route) would resemble the following:
Prefix        Next Hop       Interface 
0.0.0.0/0     192.168.5.5    FastEthernet 0/0 
Objective:
Network Principles 
Sub-Objective:
Identify Cisco Express Forwarding concepts 
References:
Cisco IOS Switching Services Configuration Guide, Release 12.2 > Cisco Express Forwarding Overview 
Cisco > Home > Support > Product Support > Routers > Cisco 12000 Series Routers > Troubleshoot and Alerts 
> Troubleshooting Technotes > Understanding Cisco Express Forwarding (CEF)https://www.ccexpert.us/traffic-share/fib-entries.html




Question 10

Which of the following IPv6/IPv4 interoperability techniques routes both IP versions simultaneously?

  • A: NAT-PT
  • B: Dual stack
  • C: 6to4 tunnels
  • D: Teredo

Correct Answer: B

When the routers in the network are capable of routing both IPv6 and IPv4 traffic, it is referred to as dual stack. 
The dual stack routers simply recognize the version a frame is using and react accordingly to each frame. Network Address Translation- Port Translation (NAT-PT) is a service that runs on a router or server that 
converts IPv4 traffic to IPv6, and vice versa. This eliminates the need for the routers or clients to be dual stack-capable. When only one router exists between the IPv4 and the IPv6 networks, this will be the only option, since all other methods listed require a dual stack capable device on each end of the tunnel. The IPv6 to IPv4 mapping can be obtained by the host from a DNS server, or the mapping can be statically defined on the NAT device. 
6to4 tunnels can be created between dual stack routers or between a dual stack router and a dual stack client. 
In either case, each tunnel endpoint will have both an IPv6 and an IPv4 address. When traffic needs to cross an area where IPv6 is not supported, the tunnel can be used to transport the IPv6 packet within an IPv4 frame. 
When the frame reaches the end of the tunnel, the IPv4 header is removed and the IPv6 frame is further routed based on its IPv6 address. 
Teredo is an alternate tunneling mechanism that encapsulates the IPv6 frame in an IPv4 UDP packet. It has the added benefit of traversing a NAT device that is converting private IP addresses to public IP addresses. 
6to4 tunnels cannot traverse NAT devices by converting private IP addresses to public IP addresses. 
Objective:
Network Principles 
Sub-Objective:
Recognize proposed changes to the network 
References:
Cisco > Home > Products and Services > Cisco IOS and NX-OS Software > Cisco IOS Technologies > IPV6 >Product Literature > White Papers > Federal Agencies and the Transition to IPv6 
Cisco > Cisco IOS IPv6 Configuration Guide, Release 15.2MT










CONNECT US

Facebook

Twitter

PROFEXAM WITH A 20% DISCOUNT

You can buy ProfExam with a 20% discount!



HOW TO OPEN VCEX AND EXAM FILES

Use ProfExam Simulator to open VCEX and EXAM files